Get in touch
Back
Resolved

West Europe, German Central & Switzland North

Completed 12 Jul at 12:00pm CEST.

Landing Page West Europe Datacenter Nova App Main Nova West Europe West Europe Germany Datacenter Nova West Europe Germany Nova Switzerland North Datacenter Switzerland North
Completed

Maintenance ended

Posted 12 Jul at 12:00pm CEST.
Started

West Europe, German Central & Switzerland North Data Center

Scheduled Maintenance: July 12th 9am – 12pm CEST
We'll be carrying out planned maintenance during this window. You may experience periods of downtime. Any questions, please reach out to support@rencore.com.

Posted 12 Jul at 09:00am CEST.